It’s a good idea to make your instructions as simple and straightforward as possible so that it is easier for people who are new at upgrading or troubleshooting.

When you’re having problems with an upgrade project, try flowing through each step of the process one by one until everything goes smoothly!

Error:The project is using an unsupported version of the Android Gradle plug-in (0.7.3).
Starting with version 0.9.0 incompatible changes were introduced in the build language.
Please read the migration guide to learn how to update your project.
Open migration guide, fix plug-in version and sync project

Warning:’android’ is deprecated; use ‘com.android.application’ instead

To fix it, an open a file called build.gradle change apply plugins to

apply plugin: 'com.android.application'

Warning:(4, 22) Old buildToolsVersion 19.0.1; recommended version is 19.1.0 or later

Because your Gradle plugin version and building tools are not matched or old that’s why show this error. to fix it try to change your buildToolsVersion updated

 compileSdkVersion 20
    buildToolsVersion '20.0.0'

Warning: Avoid using + in version numbers; can lead to unpredictable and unrepeatable builds

 (com.android.tools.build:gradle:0.7.+)

To fix it, open file called build.gradle change one line not using + blow are sample

    dependencies {
        classpath 'com.android.tools.build:gradle:0.12.2'

Error: You must use a newer version of the Android Gradle plugin. The minimum supported version is 0.12.0 and the recommended version is 0.12.2


Error: The SDK Build Tools revision (19.0.1) is too low for the project ‘: app’. The minimum required is 19.1.0

dependencies {
        classpath 'com.android.tools.build:gradle:0.12.2'
    }

To fix it, open a file called build.gradle.

in the project root, and change the Gradle version there to 0.12.2.

Affiliate Disclaimer : As an Amazon Associate I earn from qualifying purchases.