To face this type of problem upgrading your project . try to flowing instruction to solve

Error:The project is using an unsupported version of the Android Gradle plug-in (0.7.3).
Starting with version 0.9.0 incompatible changes were introduced in the build language.
Please read the migration guide to learn how to update your project.
Open migration guide, fix plug-in version and sync project

Warning:’android’ is deprecated; use ‘com.android.application’ instead
To fix it, open file called build.gradle change apply plugins to

apply plugin: 'com.android.application'

Warning:(4, 22) Old buildToolsVersion 19.0.1; recommended version is 19.1.0 or later
Because your gradle plugin version and building tools are not match or old that’s why show this error . to fix it try to change your buildToolsVersion updated

 compileSdkVersion 20
buildToolsVersion '20.0.0'

Warning: Avoid using + in version numbers; can lead to unpredictable and unrepeatable builds

 (com.android.tools.build:gradle:0.7.+)

To fix it, open file called build.gradle change one line not using + blow are sample

    dependencies {
classpath 'com.android.tools.build:gradle:0.12.2'

Error:You must use a newer version of the Android Gradle plugin. The minimum supported version is 0.12.0 and the recommended version is 0.12.2
Error:The SDK Build Tools revision (19.0.1) is too low for project ‘:app’. Minimum required is 19.1.0

dependencies {
classpath 'com.android.tools.build:gradle:0.12.2'
}

To fix it, open file called build.gradle
in the project root, and change gradle version there to 0.12.2.

SHARE
Previous articleBest HTML5 Mobile UI Frameworks For Developers
Next articleFirefox OS Apps Developing Environment Setup For Beginners

Abdullah Al Mahamud is a programmer and founder of Thedevline an Inspiration blog since 2014. live in Bangladesh. He is passionate about Technology and Design. He works on the freelancing marketplace as a freelancer and has also written for Useful Article in this blog

Leave a Reply

avatar
  Subscribe  
Notify of